Magento heeft weer een security patch uitgebracht: SUPEE-6788. Daarnaast is er een update voor de Community versie uitgebracht: Community Edition 1.9.2.2. Deze nieuwe Community versie bevat alle patches tot nu toe.

Backward compatibility probleem

Magento adviseert om zo snel mogelijk te updaten om je shop veilig te houden, maar waarschuwt wel voor een backward compatibility probleem. In de patch zit een fix die voor problemen kan zorgen met extensies en modules. Dit houdt in dat je webshop na de patch of update niet meer functioneert zoals het hoort en je misschien geen orders meer kunt ontvangen. Om deze reden heeft Magento deze specifieke fix standaard op niet actief gezet. Dit betekent dat je dus wel kunt patchen of updaten, maar om ook voor dit specifieke lek veilig te zijn, moet je ook deze fix nog implementeren. Dit kun je pas doen als alle extensies die je gebruikt compatible zijn. Hier vind je een lijst met alle extensies die niet meer goed werken na het uitvoeren van de patch.

Testen of het updaten of patchen goed is gegaan

Na het doorvoeren van de patch of update kun je op MageReport.com testen of het goed is gegaan en je webshop weer veilig is. Heb je hulp nodig bij het patchen of updaten dan kun je contact met ons opnemen.